Error when running startup animation "EVAL FAILED: pystack exhausted" in version 8.3.4

What do you want to achieve?

Run startup animation with image in SquareLine simulator with version 8.3.4 of the library.

What have you tried so far?

Imitate the widget parameters of the example widgets and also the settings of the environment used for the example.

Screenshot or video


  • SquareLine Studio version: 1.2.3
  • Operating system: Windows 11
  • Target hardware: ESP32 with ILI9341

Hello everyone, I am writing to report something that is happening to me when I want to replicate the following example that I base here: " Animation test for start screen " when importing it works correctly, however when I replicate in my project the parameters of the example I get an error in console that crashes the simulation of the same (As seen in the attached image).

Looking a little by the interface I saw that the example was configured for PC in eclipse in version 8.2.0, I changed it to version 8.3.4 maintaining eclipse and when I simulate the example it crashes with the error in console, seeing this I returned to my project and lowered the version to 8.2.0 and it worked correctly, being so the problem comes out when simulating in SquareLine with the library 8.3.4.

I wanted to ask if this affects only in SL or when exporting there is no problem, since I have configured the Arduino IDE with the library in 8.3.4 and compiles without problem, and I do not want complications by lowering the version to 8.2.0.

I remain attentive to your kind comments, best regards.