Esp32 rebooting - debugging

This morning I tried to connect to the ODBII on the machine using the MAC address or name (but without the PIN) but it refused to connect.
I haven’t tried using the old libraries yet-
My ODBII is version 2.1 and I have read on various forums that they recommend using version 1.5
What version of ODBII are you using?

You need elm with PIC18F25K80 chip.
Im not how you get to compile the sketch with newest version of espboard, cause it doesnt support setpin line of the code.

You will need that elm with that chip, or original version of elm.

I’ve tried with v2.1 and it didnt want to connect.
the PIC18F25K80 version works perfectly

In theory the difference between 2.1 and 1.5 is the support of other protocols thanks to the PIC18F25K80 chip, for example
1.sae J1850 PWM (41.6Kbaud)
2.sae J1850 VPW (10.4Kbaud)
which my machine does not use, as it uses the ISO14230-4 KWP protocol (fast init, 10.4 Kbaud)
But probably something else also changes during the connection phase (perhaps the presence or absence of the password).
Now I ordered another ODBII with that chip and version 1.5
And honestly it’s my last attempt to use esp32 yellow, otherwise I use an old phone with android 8 with which the various programs work very well with ODBII 2.1

Elmduino is based off original ELM327 chip.
V2.1 is a clone.
All i know the PIC chip works, i had issues like you I can discover the device but it doesn’t talk back. I’ve tried Mac addresses this and that, it didnt work.

Maybe if you hardwire it and use RX and TX pins u might be able to do it.

I know its frustrating…