No Font file in project

What do you want to achieve?

When I export a project having changed the font type in the GUI, the project wont build due to no font defined


Also there are no .c files in the font folder - that has been exported. It looks like the fonts are not being converted to .c files and put into the font folder on export ?

The error when building my Arduino project

D:\Projects19\Embedded\ESP32\ESP32S3_LCD\ArduinoGUITest\LvglWidgets_MergeSquareLineGUI\PCDisplay\ui_Screen1.c: In function ‘ui_Screen1_screen_init’:
D:\Projects19\Embedded\ESP32\ESP32S3_LCD\ArduinoGUITest\LvglWidgets_MergeSquareLineGUI\PCDisplay\ui_Screen1.c:153:47: error: ‘lv_font_montserrat_24’ undeclared (first use in this function); did you mean ‘lv_font_montserrat_14’?
lv_obj_set_style_text_font(ui_LoadLabel, &lv_font_montserrat_24, LV_PART_MAIN | LV_STATE_DEFAULT);

What have you tried so far?

Nothing - looks like a bug - with no workaround except not using any GUI widgets that require a font

Screenshot or video


  • SquareLine Studio version: 1.3.0 exported from SquareLine IDE and then built from ArduinoIDE via .ino sketch file
  • Operating system: Windows 10
  • Target hardware: ESP32-S3-LCD-EV-BOARD

Please check if LV_FONT_MONTSERRAT_24 is set to 1 in arduino/libraries/lv_conf.h.


I added these changes to the following file


I set the following defines to 1


and it looks like that fixed it ! Thanks.

1 Like