All project preferences gone after update to SLS 1.3.1 from 1.30

What do you want to achieve?

Simply proceed with my project as being done before, but all project setting are gone, and no options to restore them manually again, f. e. the “browse” button for File Export does not work (not funtional)
I have de-install Ver 1.3.0 before installing 1.31 in the same folder

as being suggested by the update dialog.

What have you tried so far?

To restore the project setting manually, does not work

Screenshot or video


  • SquareLine Studio version:
  • Operating system:
  • Target hardware:

Additionally to my previous error post: All dropdown boxes are empty, including the board presets.

Additionally to my two previous posts: Even de-installing and re-installing the program installtion did not help. Error log attached. (3.1 KB)

Additionally to my three previous posts: Reverting to Ver. 1.3.0 worked. All preferences back again. Conclusion: Severe bug in Ver. 1.3.1

According to the log, SquareLine Studio 1.3.1 did not have permission to access the specified folder.
UnauthorizedAccessException: Access to the path ‘C:\Program Files\SquareLine Studio 1.3.1\SquareLine’ is denied.

You probably didn’t give the program permissions during installation, or your antivirus or firewall blocked it.