Cannot login to SLS on different device

What do you want to achieve?

Trying to login to SLS on different device, getting the following error message:
“Communication error with the license server!”
However, it does provide me with the option to login and activate license.

What have you tried so far?

Thought it might be a firewall issue, but after temporarily disabling it and relaunching, trying to login again, it is still not working. So I assume it is not a firewall issue. After putting in correct login details, I get:
“ERROR: unknown license error!!”

Screenshot or video


  • SquareLine Studio version: v.1.2.0, small business license
  • Operating system: Windows 11
  • Target hardware: Intel NUC M15

Nevermind. I reinstalled and made sure to run the setup.exe as administrator and was able to login.


I’m getting exactly the same error. I can see on the web site that my Personal license is valid. However I can’t log in from the SLS. I’m on Ubuntu 2022.10, and the SLS version is v1.2.0. The password is valid as otherwise it complaints about that. No error messages appear in the console. I’ve run ./ both as a non-root user and as the root, and this did not help.

Hi @mappo,
Please send us your email address to so that we can check the status of your license.