Crash when trying to export ui

What do you want to achieve?

I want to export UI but the software crash when I click “Export UI Files” or “Create Template Project”

What have you tried so far?

To set export path in "Project Settings " but the soft crash when I click browse button…

Screenshot or video


  • SquareLine Studio version:
    Version 1.2.3
    same issue with 1.2.2
    didn’t tried lower versions
  • Operating system:
    Debian GNU/Linux 11(bullseye)
    64 bits
    GNOME 3.38.5
  • Target hardware:
    Dell Precsion M4800
    Intel i7-4910MQ
    RAM : 16Go
    CG : Nvidia NVE7

End of Player.log :
Caught fatal signal - signo:11 code:1 errno:0 addr:0x488587f80
Obtained 7 stack frames.
#0 0x007ffb101d7140 in funlockfile
#1 0x007ffb0bb4b012 in XDefaultRootWindow
#2 0x007ffb09ee6b98 in getWindowFromPid
#3 0x007ffb09ee6c7b in getUnityWindow
#4 0x007ffb09ee6efd in GTKOpenPanel
#5 0x007ffb09ee6dbb in DialogOpenFolderPanel
#6 0x000000420938ab in (wrapper managed-to-native) Crosstales.FB.Wrapper.Linux.NativeMethods:DialogOpenFolderPanel (string,string,bool)

We need the full log file to see the error. Can you send it to

I am having the same issue. Just started to evaluate the trial v1.2.3
Getting the following error: Segmentation fault (core dumped)
No log file is written.

The crash occurs during the export or while trying to setup the output folder. Regardless of the project created.
I started with an arduino based project, 1 screen and 1 button in the middle… nothing else.

Hey, had the same Problem. Running Ubuntu 24.04. Luckily rpraga wrote that this problem occurs while trying to setup the output folder. That got me thinking and i tried to run Squareline Studio as admin and it works. Maybe not the solution to the problem but definitely a workaround.


1 Like

There are some existing reports already of a crash when file-dialog is requested by SquareLine Studio.

It seems some file-browsers caused problems (Nautilus). But for example, PCManFM has no problem on my Debian Bookworm system. Good to know that admin privileges are a possible workaround too…