Exporting files into arduino

What do you want to achieve? to take my successfully exported gui project and open it inside of arduino IDE to define functions and upload to MCU

What have you tried so far? importing directly but arduino says it needs to be .ino file not c header file to open

Screenshot or video N/A


  • **SquareLine Studio version:**1.05
  • Operating system: windows
  • Target hardware: huh?

hello everyone thanks in advance for the help but i am new and wondering how i can import my project folder to arduino ide to play with inside the ide and eventually upload to my mcu how can i open in arduino?


I suggest taking a look at this great video to get started with Arduino and SquareLine Studio

1 Like

It is simple, your sketch (.ino file) should be in same folder as your exported files from SLS and this folder must have same name as your sketch.

After that, you have to include these 2 lines:

#include "ui.h"
#include "ui_helpers.h"

I would recommend to start with LVGL example for Arduino.

1 Like

and just to clarify just transfer the C header files to the arduino sketch location correct?

the video posted above goes a little to fast

when i added the files to the sketchbook it added correctly but its asking for me to include the
SDL/SDL2 library i downloaded it from github but im also not sure how to include it in the library when i try to add it as a zip library arduino tells me no library is in the folder and then i thought i would add the files like how you said above by dragging and drop but it took me like a hour and is still asking for more files to be included and now the sketch book is a mess.

can you tell me how i can add the sdl/sdl2 (i downloaded both) library to the sketch since i cant import it as a zip library?

I have folder structure like this:


which correspond to project in Arduino IDE:

As far as I know you should not need any SDL library to make SLS code work with Arduino.

If you can, share some code which are you trying to make work :wink:

1 Like

once i deleted those included libraries i got this error

onedrive\documents\arduino\libraries\lvgl\src\lv_conf_internal.h:41:103: fatal error: …/…/lv_conf.h: No such file or directory
compilation terminated.
exit status 1
Error compiling for board TTGO T-Watch.

i have the conf.h file included im just not sure what it wants me to do after that cause other than that error everything looks okay

Where do you have your lvgl_conf.h placed? It should be in libraries folder as it is here:


i have it saved here in the project files of the sketch itself

it was giving me that issue because i exported the whole project instead of just the files from the ide now that i imported the files only its playing a lot more nicely still need to debug some stuff but im feeling a lot better thanks

1 Like

Hi all,

First time trying to upload a SLS project to ESP32 Dev using Arduino IDE.
I’ve followed the “how to” video for export but I’m not having much luck.

Receiving this error:

fatal error: lvgl/lvgl.h: No such file or directory
 #include "lvgl/lvgl.h"

I’ve not altered the directory structure that was created automatically by SLS.

Thanks for any help.

What version of SLS are you using?

I have export of my project and I have this in my ui.h:

#if defined __has_include
#if __has_include("lvgl.h")
#include "lvgl.h"
#elif __has_include("lvgl/lvgl.h")
#include "lvgl/lvgl.h"
#include "lvgl.h"
#include "lvgl.h"

In what file do you have your #include "lvgl/lvgl.h"?

Thanks for the quick help!

SLS version: 1.1.1 (using Mac).

Looks like I have the "#include “lvgl/lvgl.h” in several files.

Before I saw your message, I commented out the "#include “lvgl/lvgl.h” in each file which removed the compile error.

Yet now I’m receiving many errors. I will try your solution now.

Just to test, do you recommend one of the SLS examples that you’ve successfully loaded onto ESP32 dev using Arduino IDE?

Thank you again for the help.

I tried loading the “Thermostat” example yet getting a compilation error:

Compilation error: expected ';' before 'const'

Looks like this is in reference to one of the bitmap commands.

Please attach the whole build log.