Issue compling in arduino with ttgo twatch (v1 2020)

What do you want to achieve?

fix error code

ui.c:48:6: error: #error “LV_COLOR_DEPTH should be 32bit to match SquareLine Studio’s settings”
#error “LV_COLOR_DEPTH should be 32bit to match SquareLine Studio’s settings”

What have you tried so far?

adding in config file and trying find screens byte per pixel

Screenshot or video


  • **SquareLine Studio version:**1.06
  • Operating system: windows
  • Target hardware: ttgo v1 2020

hello im wondering if anyone with the ttgo v1 watch has gotten the export files from to complie for my project it gives me the error code above and im not sure how many byte per pixel my screen is does anyone know? (ive unable to find it online)

and if it CAN handle 32 bit do i need to declare anything in the code to run it?

1 Like

i was basically watching this video

and about 8:15 ish in the video he gets the config.h file and edits it,ive followed that and done the same but when i run the code it still gives me a error about the fonts so in the code ive included #include “lv_conf.h” in the file that is giving me the error but it still occurs.

i have the lv_conf.h file saved in the same folder as the arduino sketch but in the video i did not see him do this nor did i see it on the github page,so do i save the lv_config.h file in the arduino folder or do something else in this scenario?

1 Like


so i did find out that the lv_config file DOES belong in the lvgl library as a header file and i did at it in the SRC file inside of it but it also says inside the file

  • Copy this file as lv_conf.h
    1. simply next to the lvgl folder
    1. or any other places and
    • add the path as include path

on step two where do i define that and what is the syntax i use?
and where do i add the path? do i define it within the syntax or somewhere else?

1 Like

Did you follow this guide from docs?

Also look in SLS → File → Project Settings what color depth you have and then match it to either conf file or change color depth in your project. What is compiler telling you is that you have (probaly) set your project to 32bit, but your config is set to 16bit color depth. I would recommend to go with 16bit color depth. :wink:


thanks for the guide i missed that guide,i managed to get the font errors worked out i have over 100 errors now lol so i guess im missing something basic,im gonna stay on the prowl hopefully i can get something uploaded tonight thanks again for your help!

1 Like