Issues with SLS 1.4.0

What do you want to achieve?

What is going on with Square Line Studio?!
I made a change to a screen by accident and tried to undo the change but there does not appear to be an undo/redo feature anymore? So I decided just to close SLS and discard the changes and noticed that it does not warn me that the changes have not been saved !

What have you tried so far?


Screenshot or video



  • SLS 1.4.0
  • Windows 11 x64

Am I missing the obvious?


Undo/redo engine was reported to be problematic, but it is improved now, and will be working well in the next release.

What keypress is undo/redo and why do they not appear under any menu?


The usual Control+Z and Control+Y. There are screen buttons with circular arrows that do the same. Undo-history size can be set in Preferences. (Too big number there might lead to big memory consumption.)

Control+Z and Control+Y do nothing for me!
What screen buttons?

Am I blind, I can’t see any circular buttons :frowning:


Probably you have the above-mentioned ‘Undo-history’ size set to ‘Off’ in Preferences. It’s turned off by default in SquareLine Studio 1.4 because of the need for improvement of this feature. (It’s already improved and will be well-behaving in the next release.)

Yes, that was it :slight_smile:
You have a bug though, with Undo turned off, SLS does not warn you that you have unsaved edits when you close down the program.


I also think Undo should be enabled by default perhaps with the lowest level if there are performance issues with it.


AFAIK there are not only performance issues, that’s why it was disabled by default for a while.
I could reproduce the problem you’re talking about, i.e. SquareLine Studio 1.4 not notifying about unsaved progress at exiting if undo history is turned off. Thanks for the feedback, I create an issue for the respective staff.