Linux support Ubuntu 20.04

Ubuntu 20.04 support

Dear team already mentioned in the this thread.

I have some troubles to run version 1.0.4 in Ubuntu 20.04

From support I had some ideas to check where the issue is… I found out that running your specific micropython port on Ubuntu 20.04 resulted in

./micropython: /lib/x86_64-linux-gnu/ version GLIBC_2.33' not found (required by ./micropython) ./micropython: /lib/x86_64-linux-gnu/ version GLIBC_2.34’ not found (required by ./micropython)

Next I followed the instructions on
GitHub - lvgl/lv_micropython: Micropython bindings to LVGL for Embedded devices, Unix and JavaScript to build the unix port. This resulted in a working server :slight_smile:

But unfortunately I couldn’t get a working example.

What can I do to get the examples working? I only have 13 days left on trial and haven’t tested anything.


We are looking into this. The server is a customized version of lv_micropython so the upstream version won’t work.

We will send you a new server to try it out soon, and make your trial longer.

In the meantime can you try v1.0.3 out?

Please try this server (1.0 MB)

Thanks… this micropython version works under Ubuntu 20.04.

Great, thanks for the feedback!
We will built this server on an older OS, and will keep using it in the new versions.

I currently have the same problem in Lubuntu 20.04, with Studio v1.04. The alternative server (above) has no effect.

Have you run

Yes… However, I don’t see a .desktop entry in ~/.local/share/applications. :thinking:


  1. From the command line, I executed each line in separately. This successfully generated a .desktop entry. Oddly, running the script is not successful.
  2. At this point, only the alternative server (above) works. The server supplied with Studio v1.04 does not work.

Hmm, it’s really interesting. There is nothing special in that shell script.

Thanks for the feedback! It will be fixed in v1.0.5

When executing, the command:

mv squareline_studio.desktop ~/.local/share/applications

renames “squareline_studio.desktop” to “applications” and moves it to the following directory:


Yes, tilde (~) points to my home directory.

This is truly odd. :thinking:

Hmm, it’s really strange. Others haven’t reported similar issue so I think it should be something with your system. But I have no idea what could it be. :frowning: Assuming that you have started the script as user and nor root.

I’ve the same issue with SLS v1.0.5 on Ubuntu 18.04 LTS. The micropython coming with SLS v1.0.5 gives the same error as the micropython provided here in this thread, but to my suprise it complains about a different GLIBC version:

./micropython: /lib/x86_64-linux-gnu/ version `GLIBC_2.29' not found (required by ./micropython)

Installed is version 2.27, so the error message certainly makes sense, but I can’t try out SLS with this “bug”.

We have built micropython under Linux Mint 20.3 (Una) which is based on Ubuntu 20.04. I see no problem with using Ubuntu 18.04 instead.

I can try it out next week and send the binary to you for testing.


I rebuild the server with Ubuntu 18.04.

Please copy unzip the attached file and copy micropython to the server folder of SquareLine. Don’t forget to make it executable with chmod +x micropython. (1.0 MB)

1 Like

Thanks a lot for LVGL, Squareline Studio and your effort! It works now for me and I hope also others who still use Ubuntu 18.04 find it useful. I know that I should have upgraded to a newer Ubuntu already, but I tried a 22.04 recently and the graphics drivers are completely messed up for me. I’m undecided and may even stick to 18.04 for a while (newer change a running system).

Great, compiling the server under 18.04 is fine for us too so we will use it in the future.

I’ve also tried Ubuntu 22.04 but Gnome was… well… almost made me cry… :smiley: So now I’m on Linux Mint Debian Edition.