Lot of serious bugs v1.4.0

What do you want to achieve?

Open my project and continue working on it

What have you tried so far?

nothing, do not know where to start

Screenshot or video

Others

  • SquareLine Studio version:
  • Operating system:
  • Target hardware:

MacOS Monterey (Intel i7)

The error is: after importing the project, a “Rebuilding all screens…” message appeared and cannot continue the development. I did not do anything, previously it worked. Please help me.
Error in the attachment:

… ok deleting and recreating the widget in the error log solved the issue, but after a couple of editor restarts, another widget throw this error. It’s kind of a never-ending game…
and found another bug: when exporting the project there are missing UI widgets (textarea), also some widgets has different (random) position than in the editor. Rebuild all screens did not help. update1: taking a closer look, it seems the coordinate system of the editor is different than the exported project. For example, the Y coordinate of my widget in the editor is 187, however there are an old widget in the same Y position with value of 95. And i guess this is same for the X coordinate (45 vs. -210).

…also it seems the editor randomly forgets settings that I’ve already set (ie. export path for project).

…in addition, I can confirm that the drawing performance degraded from SLS 1.3.3 to 1.4.0, ie. moving the colorwheel knob started to lag, also when opening up the dropdown widget i can see noticeable drawing delay which was not present before (maybe LVGL 8.3.11 has brought in to the picture, i do not really know)

…and not to mention the CPU load is around constant 100% when working with the SLS editor (maybe it is because of i am using the Intel version of SquareLine Studio on Mac, but this is not acceptable under any circumstances…

I really disappointed with this version of SquareLine studio

I have the same error, just adding a new sceen, save the project, close the projet and reopen it →
grafik

thanks @Syr0x that does it.

the most annoying however is that the textarea has wrong X and Y coordinates generated in the editor. So i cannot estimate the exact position where it will be rendered… at least this should be fixed in the next release :frowning:

Indeed, TextArea coordinates are set and exported for ‘TOP_LEFT’ orientation in SquareLine Studio, not respecting if there’s ‘CENTER’ set in alignment field. I’ll report this to the respective team. Until that the workaround is to set ‘TOP_LEFT’ in the Inspector panel so that the export will be correct.

thank you @Hermit i’m gonna try it.

also, found another bug: i copied my project files from Mac (macOS Monterey) to another computer (Windows10). The SLS version is the same (1.4.0) on both. I could open the projects, edit, then save. Once I wanted to open the project on my Mac which was saved on Windows10 , it says “The document could not be opened”, see:
image

did i lost all my work i’m done on the windows??

Can you send the log-file (or maybe projectfile) to forum@squareline.io? (info about log-file location: Troubleshooting | SquareLine Studio). I suspect that you got some unix permission changes while you were on Windows (maybe try chmod-ing all files to e.g. 644), but maybe it’s some project-path setting specific issue. A log file could tell more about the real cause…

i can send you the log file here:
Player.log.zip (1.9 KB)

does not contain anything interested. However, one thing i did not mention: as i do not want to revoke my licence all the time i created another user for my windows desktop, so when i am at home i can do my work there (big display, more convenient…), during traveling i can use my other licence with my macbook.
Does it have any effect on the issue?

The error message in log seems to indicate a communication problem with the licence-server, and yes, it can be related to hardware/OS-change (revoke). I forwarded the log to the respective staff, hopefully you’ll get a tip/resolution soon.