Moving widgets from screen to screen

What do you want to achieve?

I want to move a whole sub-tree of widgets from one screen to another.
Before, we were able to drag them easily in the tree, from one screen to the other.
Now screens are in a separate tab, we have to switch screens beore and can’t see the whole tree in one place.

What have you tried so far?

I tried copy / paste, but as I need to paste before deleting the original tree, the pasted copy is renamed with _2 suffix for every widget. For big sub-trees, it’s breaking every reference and we need to rename every widget manually.

Screenshot or video


  • SquareLine Studio version:
  • Operating system:
  • Target hardware:

You should set the layout so the ‘Screens’ and ‘Hierarchy’ panels are seen at the same time. Then you’ll be able to move the widget group to the other screen by dragging its top/parent widget and dropping it to the target screen.

Hi, thanks for the suggestion, but I already tried this and it does not work. It’s not possible to drag the hierarchy outside of the “Hierarchy” panel, and onto to other screen in the “Screens” panel, for me.
As we have a “copy” option on the entry, it would be easy to add a “cut” option, in order to “paste” it at the target location.
For now, I’m unable to extract a whole part of the work in this separate screen.

I just probed it in SquareLine Studio 1.3.4 in different scenarios on Debian and in Windows, still seems to work with separate widgets and hierarchical widget-groups too (tested with one-level deep group). You have to grab the widget icon in Hierarchy panel and drag it to the screen-icon in Screen panel. A bit laggy, or you won’t necessarily see the top widget’s icon throughout the dragging, but if you move the mouse-cursor to the target screen in the screen panel, it will drop the widget group into it. If you still don’t have luck with the newest SquareLine Studio a bit more details, how your setup differs from the one we tested, might help to reveal the problem…

Hi, thank you for your investigations.
I can confirm the problem exists, but I managed to identify the possible causes.

I was spreading the contents of a tabset into several screens. The entry I was trying to move across screens was the “tab” element. Looks like it’s not possible to move it straight, as it should belong to a tabset. Moving other types of entries did work the way you describe, though.


  • Moving an entry (or subtree) should display an icon on the drag-n-drop operation
  • Trying to move an entry that is not eligible (like a tab) should show a stop sign icon instead so that we know explicitly it’s not possible
  • Eventually, a status bas on the app, would be great to provide feedback for operations, such as “Subtree move successfully to screen XXX”. Can be used for any operation.

Thanks for your help !