New Font viewing

What do you want to achieve?

Create a new font Arial 24

What have you tried so far?

Follow all instructions on Youtube video

Screenshot or video


  • SquareLine Studio version: 1.1.1, 1.2.0 and 1.2.1
  • Operating system: Windows 10
  • Target hardware: Arduino

After create the new font, and select it on label Style Inspector, display shows a blank small box (no text).
Arial font is installed on Windows.
What am I doing wrong?

What is the language of the text you want to display? Note that if it’s not ASCII (English) you need to add the Unicode range of the extra characters to the font converter.

Hi @kisvegabor ! I am using English.
In fact, I just opened the thermostat example and there is no text on the middle (using NUmber font).
I think this is a compatibility problem, like some java ou python preveously installed in my machine.

I don’t think it’s a compatibility issue as we use and exe in which LVGL and MicroPython is built together. So SLS desn’t use “normal Python”.

Please send a screenshot about the content of the Console Panel and send the logs as described here.

Here is the capture and logs.

Can’t upload log (new user)…

… and I tried to re-install 2 times, installed version 1.1.1, 1.2.0, and same problem.


I’ve just increased you “trust level”. Now you should be able to upload files.


Now here is the log files… (6.5 KB)

There is nothing extraordinary in log. Could you attach the project too?

That’s my point! I just started an example project. Any one, same problem: rendering fonts and other stuffs.

Actually it’s more than an untouched example project as you mentioned

I have no idea what, but maybe something when wrong with it. Anyway, if we can reproduce it, we can fix it too. That’s why we need your project.

Here is the project, but I don’t think the problem is this (I’ve just installed lasted version of SquareLine 1_2_2 and opened a sample project). (148.4 KB)

Unfortunately, it works for me. :frowning:

I cc one of our developers, hopefully he will have some ideas.

If you want to create a new font, you need to copy the font file to your project/assets folder. You can find the font file in the C:\Windows\Fonts folder. After copying, the font will appear in the font management panel. You can read more about this in the document.

It’s not about to create a new font. It’s about the rendering ui server. It’s not working… even another examples projects, lik ebike or audio_mixer.

For some reason the image can’t be loaded. Can you share the full path of the project? Maybe there is a character in the username or so which makes the loading broken.

I got it ! That’s the real problem. I saved in a root directory (C:\Temp) and everything works.
So, maybe you can improve your code to manage to write a project in a OneDrive directory, with special characters.

I can’t share the fulll path here (it’s a public forum), but I assure that is a long name with portuguese characters.

Thank you for your help.

Could you send the path as an example in private?

How can I send in private ?