Project corruption / memory leak - requires reboot

What do you want to achieve?

Trying to use 1.1.0 Beta 1 - but program hangs after extended use (particularly if left open overnight) and when project reloads the screens are greyed out and no widgets are shown, despite the widgets being shown in the hierarchy.

What have you tried so far?

I tried closing and re-opening SLS, but project appears “corrupted”. I had tried going to backups or autosaves but always get the greyed out screens.

Tried creating an empty project, but it too was greyed out.

Tried deleting the Documents/SquareLine, re-running SLS (having it re-create that directory) and creating a new project. Same greyout out screen.

Only rebooting the PC was able to make SLS load the project again without “greyed out” screens.

Screenshot or video

(sorry for the screenshot of my detailed post - but new users are limited to one embedded image, and I only found out when I clicked Create Topic)


  • SquareLine Studio version: 1.1.0 Beta1
  • Operating system: windows 10
  • Target hardware: Arduino


LVGL and SquareLine communicates via a localhost socket. I think can be related to a dead socket or so. We are looking into it.

Using TCPview - I was able to search for port 20085 that SLS was trying to communicate with and there was a micropython.exe process running with an earlier creation time. Killing that process brought the GUI back to life and all the widgets appeared where previously they were greyed out.

Hope this provides a clue. It takes a while before the corruption occurs, so it’s hard for me to check, but if there’s anything else you want me to check next time it occurs, let me know.

Thank you!