Project Editor Window grey


SquareLine works great.

But suddenly, my UI Editor looks like this:

(UI Preview is grey. It should show the UI I built)

Does someone know how to fix this? Thanks

What do you want to achieve?

Fix my UI Editor

What have you tried so far?

  • Close and restart SquareLine
  • Reboot Computer


  • SquareLine Studio version: 1.1.0
  • Operating system: MAC OS Monterey Version 12.4
  • Target hardware: Arduino / ESP3

Ok, I fixed it by unpacking one of the older backup files.

I’ve had this same issue. It’s happened to me twice. Both times when I pressed “Ctrl Z” to undo something. The first time I was able to get it back by rebooting, but not this time. All my backup folders just have .spj files, but the corrupt file is the .sll file, so that didn’t help.
I was able to get a backup by going to another branch in git, but I lost an hour’s worth of work.

It happened to me again. It seems to be related to using git. I’ve now lost another 2 hours of work. Any suggestions on how to recover the files? The backups aren’t helping.

Do you use v1.1.1?

yes. I am using v1.1.1
One part of the failure mode is that the .sll file fills up with this…

It also seems to be related to using git, though I’m not 100% sure about that.

I just downloaded on mac and whatever I do, all I see is this screen with the transparent bg. Even the examples doesn’t work.

Running version 1.1.1 on a Mac with M1 chip

Please take a look at this: Troubleshooting | SquareLine Studio

Same here. Backup project that worked yesterday would not import. Using latest version of squareline studio.

Second time that this happened to me.

Thought this was a oneoff and redesigned complete display design yesterday. …Gone again today!

All widgets are upper left corner with 1px in size.

Sorry for the inconvenience. In order to investigate the issue please send a screenshot about the content of the “Console” panel in SLS and also the attached the logs as described here.

Hello, I use the version of 1.3.1, also happened the same problem, do not know how to solve!

Please send a screenshot about the Console panel of SquareLine Studio.

Which OS do you use?

Same problem same solution. In your project you add some object or event (try remove last changes) , that corrupt rendering process. This bug exist in every SQS version and marking with lightning symbol is very informative… Maybe SQS coders add some real info in next versions.