Resulting code looking in incorrect directory for lv_conf.h file

What do you want to achieve?

I can create a UI and get this running well with my Lilygo T-Display ESP32S3 board, but for some reason unknown to me, when the resulting code looks for the settings in the accompanying lv_conf.h file, it gets these settings from a similarly named file elsewhere on my Mac.

What have you tried so far?

I have tried renaming the file that is actually referenced to see if the code will automatically locate the correct lv_conf.h file in the accompanying project directory under the lvgl folder. The file is there, but it isn’t the one that gets referenced which is what I don’t fully understand.

The screenshots show the error generated by the ArduinoIDE where I have renamed the lv_conf.h file in the location where the file should not be being referenced from, and also shows that there is an actual file named lv_conf.h in the project hierarchy where it should be being referenced from.

Could someone let me know how I get the code to correctly reference the lv_conf.h file in the project folders please.



  • SquareLine Studio version: latest version 1.2.1
  • Operating system: MacOS
  • Target hardware: Lilygo T-Display ESP32S3

Have you exported an Arduino with TFT_eSPI project? If so, have you followed the instructions in the README? Especially