Screen does not render in version 1.2.2

What do you want to achieve?

Creating any new project in version 1.2.2 results in a non-rendered screen.
Rendering seems to fail due to errors when creating the new project (see console output).

What have you tried so far?

Examples can be opened and are rendered correctly.

Screenshot or video



  • SquareLine Studio version: 1.2.2
  • Operating system: W10
  • Target hardware: does not matter
1 Like

I saw this too, after attempting to update a cloned image components image I couldn’t get the simulator to show the update (only the inspector panel), while the uncloned image widget did update when I changed its asset.
Then saving and closing destroyed my project. Since then I am seeing this and also a font generator error

I have the same problem, the screen wont render

I have seen this as well. The project was going fine and then I tried to add a button and it kept sticking it at the top left of the screen. All the elements of my design were still there and all the x,y and sizes were correct, it just wouldn’t show on the screen. This screen is full of panels and buttons and stuff but it just won’t show. I closed and reopened the project but to no avail.
Edit: I just rebooted but it is still the same.

I tried to upload an image of the console but new users can only upload one image so that is crap. I tried to cut and paste the text from the console but it is not copyable.
One line of interest is “EXCEPTION BB SEND name ‘ui_Screen1’ isn’t defined”

Edit 2: There is a screen called “Screen1” so I changed the name of it to “Main”. I saved and tried to repoen the project and I get “EXCEPTION BB SEND name ‘ui_Main’ isn’t defined”

Thank you for the report.

@Marton could you take a look at this topic?

@tyeth Hi, please check your Range settings in font panel. You have to set of chars what you would like to use with your font.
The default range is: 0x20-0x7f (ASCII Standard)
your range is empty, so you would like to export zero characters. You can set your range by dropdown, or you can define your custom range (your custom is empty at the moment)
You can check more information about ranges:

  • -r, --range - single glyph or range + optional mapping, belongs to previously declared --font. Can be used multiple times. Examples:
  • -r 0x1F450 - single value, dec or hex format.
  • -r 0x1F450-0x1F470 - range.
  • -r '0x1F450=>0xF005' - single glyph with mapping.
  • -r '0x1F450-0x1F470=>0xF005' - range with mapping.
  • -r 0x1F450 -r 0x1F451-0x1F470 - 2 ranges.
  • -r 0x1F450,0x1F451-0x1F470 - the same as above, but defined with single -r.

@mattb351 We can’t reproduce this bug, please send more information:

  • os version
  • selected board and lvgl version
  • a playerprefs log file, when the error appears
  • a small test project or any custom file where the problem occurs
  • a step-by-step process, how we can reproduce the bug with your test files/project
    thanks for your help


Same here.
A project created in 1.20 & 1.21 does not render at all…nothing but checkerboard screens.
Single screen version attached (13.1 KB)

I did not change or remove the default ascii range of x20-FF or whatever, although anything is possible (accidents do happen). The software should also accept no range with symbols or provide an error to the user if they have invalid options rather than supplying the range argument to the java utility with no value which is obviously not going to work.

Edition: Windows 10 Pro
Version: 21H2
OS build: 19044.2728
Experience Windows Feature Experience Pack: 120.2212.4190.0

LVGL 8.3.0

Board: Desktop, Visual Studio 2019 for Windows

I’m not sure how to generate a playerprefs log file. What’s the procedure?
I just tried to upload a project, but new users are not allowed to upload anything.
I created a link in Tresorit to a project which shows trhe bug it so you will have to get it from here

I just open the project in 1.2.2 and it won’t show anything. It opens fine in 1.2.1. In fact I think it was originally created in 1.2.1.

Same Problem…

Same problem here. Everything created in 1.2.1 cannot be loaded correctly in 1.2.2.

OS: macOS 12.6.3, running with Rosetta2 enabled

I am in the same situation.
Is using v1.2.1 the only way for now?

Solved in version 1.2.3

Solved for me too.


1 Like

I upgraded to 1.2.3. Still i see the same issue.
Kindly help to resolve the issue

This issue should have been resolved now.
Can you check what the console output displays?
Can you try a new project?

1.2.3 works for me now