SLS occasionally fatally corrupts project settings

SLS V1.2.3, Win 7/64, Node.js V11.15.0 with NODE_SKIP_PLATFORM_CHECK enabled.

Associated .SPJ with SLS in an attempt to launch different projects by double clicking on the .SPJ; this does not appear to work as expected.

Created simple GUI project, exported and built using Arduino IDE for ESP32, saved project then exited SLS.

Started SLS and reloading saved project. This sporadically results in partially loaded SYSTEM SETTING page with lots previously filled in fields now blank and un-editable. The only fix has been to completely create a new project from scratch which is a teeeeny bit tedious.

See SLS/ SLS_test_04.rar for screenshots, as well as associated SPJ and SLL files.

Any help appreciated.


Try 1.3.0 and report. (Dont use double click open…)


Looks like SLS uses The Registry for some settings. How do I completely clean out the previous installation before installing 1.3.0 ?


We have tried to load the project and it worked well for us.

Please copy the project to your Desktop (I assume it’s on the C drive) and try loading it from there.

So far so good with V1.3.0, no project corruptions this far…

Thanks for your help.