SquareLine 1.3.2 does not display screens

Any project I open with SquareLine v1.3.2, including the example projects, just displays gray checkerboard for all screens. All objects have their handles near 0,0 and don’t display at all.

Exporting Code works, and generates identical code as v1.3.1 (except for the version number at the top of each file).

But the editor is unusable.


  • SquareLine Studio version: v1.3.2
  • Operating system: MacOS 13.4.1
1 Like

Here is the contents of the log from ~/Library/Logs/SquareLine\ Kft_/SquareLine_Studio/Player.log

Player.log.zip (18.7 KB)

SLS cannot find or does not have permissions to the KS_Diagnostics_Process.dylib file. Please check whether this file is in the SquareLine_Studio.app\Contents\PlugIns folder. You can open the folders within the application by right-clicking on the SquareLine_Studio.app file and selecting the “show package contents” menu.

Thanks for the response.
That file is in the correct place, and has read permission for all users (plus write permission for my username).

$ ls -l /Applications/SquareLine_Studio.app/Contents/PlugIns 
total 16776
drwxr-xr-x@ 3 dann  staff       96 Aug 30 04:53 FileBrowser.bundle
-rw-rw-r--@ 1 dann  staff  8587840 Aug 30 05:11 KS_Diagnostics_Process.dylib

I also tried giving that file full permissions:

$ chmod 777 /Applications/SquareLine_Studio.app/Contents/PlugIns/KS_Diagnostics_Process.dylib
$ ls -l /Applications/SquareLine_Studio.app/Contents/PlugIns                                 
total 16776
drwxr-xr-x@ 3 dann  staff       96 Aug 30 04:53 FileBrowser.bundle
-rwxrwxrwx@ 1 dann  staff  8587840 Aug 30 05:11 KS_Diagnostics_Process.dylib

But running SquareLine_Studio does the same thing (screens are not displayed).
I’ve tried this on two computers, both macs, and my co-worker (who also has a license) is having the same issue on his mac.

Do any Macs have an M1 or M2 CPU?

Yes, they are all M1 or M2

Hi, same problem here: the centre editor si blank (well, the checkered canvas at least).
I’m using a Mac M2 device.
Any news ?

1 Like

Aha! Doing Get Info on the app, and then checking “Open using Rosetta” works!

It’s odd that previous versions did not need this.

Well, at least it works now.

1 Like

Hi, how do you fix it?

Ah sorry i didn’t see the whole answer.

same here after initial upgrade to 1.3.2
Apple M1, Ventura 13.5.1 (22G90)

after exit/start, SQS crashes on startup with or without Rosetta
erase/reinstall: does not even crash anymore - zero reaction
reboot does not help
stepping back to SQS 1.3.1: does not start anymore either

pardon my french: this sucks

  • Michael

Using Rosetta seems to be the current workaround, works for me. Waiting for the general fix, thanks.

How could you possibly pass testing before releasing this? Seems silly to pay for a product that seems to be a hobby project…


We have tested on an Intel Mac so far. Now we have an M1 Mac as well, so there shouldn’t be issues like this in the future.

1 Like

can you share an ETA for a working Apple Silicon version?

three weeks DOA is a pretty long in my book for a paid version.

@kisvegabor can I kindly ask for an answer.

Our project is blocked, and we actually relied on this product - which might look as too optimistic in retrospect.

Any news on this issue? This happened to a project that I was working on after upgrading from 1.3.1 to 1.3.2 on my M1 Pro MacBook Pro. Running in Rosetta mode didn’t change my outcome…

Also, I have tried exporting the project on a Windows 10 machine which leads to the same outcome.

Try play song about this > Money for nothing, chicks for free

But realy W10 work ok , what is your trouble on windows?

my recommendation is to revert to 1.3.1 and limp along until the web-based version comes out

I’m on a Apple M1 notebook, and could not start 1.3.2 nor could I revert to 1.3.1 and start that

to successfully revert, I had to remove various artefacts from the previous installation or Squareline Studio would not start at all

Obviously the newer installs leave artefacts lying around which interfere with stepping back. Suspecting this is the case, I did the following:

BigMac-833:Library mah$ find . -print |grep -i squareli
./Application Support/Code/User/workspaceStorage/a5dbe795e5d3aef56352dda8038edff3/ms-vscode.cpptools/lv_port_esp32_squareline_studio
./Application Support/Code/User/workspaceStorage/a5dbe795e5d3aef56352dda8038edff3/ms-vscode.cpptools/lv_port_esp32_squareline_studio/.browse.VC.db
./Application Support/CrashReporter/SquareLine_Studio_E5E9D816-ADF9-5FD3-9567-043E85109A62.plist
./Application Support/com.gerver.squarelinestudio
./Application Support/com.gerver.squarelinestudio/fdm.dat
./Saved Application State/com.gerver.squarelinestudio.savedState
./Saved Application State/com.gerver.squarelinestudio.savedState/windows.plist
./Saved Application State/com.gerver.squarelinestudio.savedState/data.data
./Saved Application State/com.gerver.squarelinestudio.savedState/restorecount.plist
./Logs/SquareLine Kft_
./Logs/SquareLine Kft_/SquareLine_Studio
./Logs/SquareLine Kft_/SquareLine_Studio/Player.log
./Logs/SquareLine Kft_/SquareLine_Studio/Player-prev.log

and wipe every file.
Remove /Applications/SquareLine_Studio.app

Reinstall 1.3.1 which actually comes up.




I found in my case that moving /Users//Preferences/com.gerver.squarelinestudio.plist out of the way makes it possible to restart SquareLine_Studio

I suspice ‘gerver’ stands for ‘german version’ so you might try ’ ls *squarelinestudio.plist’

you loose stored login information and the list of projects but at least the damn thing comes up

1 Like