Squareline couldn't find arduino while creating the project

When creating a project, there are only desktop options available and no options for Arduino. I hope to receive some help. Thank you.

Are you sure you have internet connections?

I am having the same issue as the other user

Just the desktop option nothing else. I do have active internet connection and no firewall blocks

I got it working but the solution is quite strange. Since you asked to validate the other user’s internet connection, I assume this has to do something with downloading the appropriate modules from server end.

I tried switching to a VPN diverting my traffic from a different country and it worked. Now I see all the other modules.

The fact that I was able to login successfully from my machine without VPN in first place (you can see it on the first screenshot that I was logged in earlier) makes this quite strange !!

Now I tried disabling my VPN and restarted Sqaureline studio and I still have arduino module. So I am good to go.

By the way, this is a great tool that you have built. Kudos for the efforts.