Stability issues


First of all; I really appreciate you guys bringing a new UI design tool on the market which is appropriate for designing embedded UIs. It is highly needed. :slight_smile:

I’ve been evaluating it on a trial license as we are in need of something like this for our small business.
However, Im experiencing some showstopping issues.

1.0.4 tend to be very slow/unresponsive or hang/freeze very often. Initially, I wasn’t even able to start it up before it hang. Restarting it a few times I got into the editor window where it seemed functional for a short period. But sometimes it starts up showing any widgets in the project as zero sized dots in upper left corner of the canvas if I get that far before it freeze up. In other words, 1.0.4 is just broken on my system.
1.0.3 is almost usable - at least, it seems slightly more stable. So initially I downgraded to that one.
First thing. When runniong ‘normally’ SL-Studio occupies about 80% GPU power constantly on the integrated GPU (Intel HD Graphics). but does not seem to use the dedicated GPU (Radeon RX Vega M). When the window is not in focus, this drops to about 30% GPU load. Slightly worrying considering it is supposed to be a light-weight UI framework. Quite strange to me that it even need to use the GPU at all and why it chooses to put the load on the integrated GPU rather than the more powerful dedicated one.
Those things aside. I also quite often see freezes and unresponsiveness with 1.0.3 to the level where I am not really able to evaluate it.
A major bug I experience in 1.0.3: Whenever I push the minimize button on the main window, the application just closes. There’s popup showing an exclamation sign for a few seconds (probably it is doing a crash dump or something)

1.0.2 seems much more stable. Also GPU usage is lower (about 20% on the integrated GPU).

Tried upgrading/downgrading between 1.0.2, 1.0.3 and 1.0.4. Situation remains the same that 1.0.4 is just not working. 1.0.3 slightly better. 1.0.2 best. Not looking forward to 1.0.5 :frowning:

I’m using a Dell XPS 15-9575.
Windows 11 (hmm… maybe I should try to see if it works better on Linux)
RAM : 16 GB
CPU : Core i7-8705G @ 3.1GHz
GPU0 : Intel HD Graphics 630
GPU1 : Radeon RX Vega M
Using 2x external screens connected to a docking station.

This is not supposed to be a rant :slight_smile: keep up the good work. Hopefully you end up with a usefull tool…

Best Regards,

1 Like


Sorry for the late reply. Somehow your post was flagged as spam and I’ve just noticed it.

For 1.0.4 please try copying this .bat file next to SquareLine_Studio.exe and start the bat file. It start SLS with different GPU settings. (183 Bytes)

If it’s still not working or you experience any of the mentioned issues please send the logs of SLS from
C:\Users\<your username>\AppData\LocalLow\Game-Ever Bt_\SquareLine_Studio\Player.log
C:/Users/<your username>/AppData/Local/Temp/Game-Ever Bt_/SquareLine_Studio/Crashes


Thanks for getting back to me. It seemed kinda fishy that my message was put on hold. Glad to hear it was an error :slightly_smiling_face:
The ‘-force-opengl’ does seem to fix the issue with 1.0.4 at first glance. I will try to evaluate it further…

Still kind of surprised about how much load the application puts on the GPU(s) for rendering a simple 2D interface. Now both GPUs in my system is put to work. Anyhow, as long as it works, it doesn’t matter much I guess…
Quite easy to see on both GPU and CPU usage when the app was launched :wink: :

1 Like

Happy to hear that. Thanks for the feedback! :slight_smile:

1 Like

Recently I have started using Squareline Studio and I was amaze while making HMIs. It works very smooth and stable with Less functionality but when it comes to multiple screen IT CRASHES AND HANGS reset is the only way to get back with no guarantee when it will crash again.

I have used trial version of Squareline 1.3.4 and i thought may be this version is buggy and i used 1.3.1 comparitively less but still screen freezes.

Am i doing something wrong and if not then kindly give solution

Is your HMI code what is freezing? Maybe your hardware doesn’t like lvgl’s internal memory allocation routines and setting LV_MEM_CUSTOM to 1 in lv_conf.h will solve the freezing. It did many times for me and others on the forum…

Thanks for your solution, it was the heap getting overflowed so changed

/*Size of the memory available for `lv_mem_alloc()` in bytes (>= 2kB)*/
   #define LV_MEM_SIZE (48U * 1024U)


    /*Size of the memory available for `lv_mem_alloc()` in bytes (>= 2kB)*/
    #define LV_MEM_SIZE (100U * 1024U) 

and it worked

1 Like

Yes, that’s the other way (increasing LV_MEM_SIZE) to solve this, e.g. if you want to keep LV_MEM_CUSTOM at 0.