Stuck in project loading

What do you want to achieve?

I want to Import project generated with SLS 1.1.1 to SLS 1.3.0

What have you tried so far?

When I import a project, it gets stuck on project loading. However, it successfully imports all the assets.

Screenshot or video


  • SquareLine Studio version: 1.3.0
  • Operating system: Windows 10 Pro

@kisvegabor Please help.

Could you send your project to so that we can try it out?

Ok. Sharing it now.

It seems the problem is that the image assets has “ugly” names. If we renamed them to have less than 9 numbers on the ends and have no special characters it works well.

1 Like

You mean firstly I have to rename all the assets directly at /SquareLine/assets/, then import the project?

Yes, if you rename the images with more than 9 digits at the end, your project will start.

Thanks, It worked.
I updated all the assets name.

one more issue, I’m not able use save as option to save the project at newer location.
When I do so, I get below error-

You probably tried to save with the save as function to the opened projects.

yes, I wanted to save with different project name at different location.