The menu "Export File" cannot proceed

What do you want to achieve?

I want to proceed to the menu “Export File”.

What have you tried so far?

Screenshot or video

Others

  • **SquareLine Studio version:1.0.5
  • **Operating system: mac mini m1 - 12.3.1
  • **Target hardware: esp32
1 Like

Does it work if you go to File → Project settings and Browse a folder there?

In either case please attache the logs from ~/Library/Logs/unity3d/Game-Ever Bt_/SquareLine_Studio/

Even if I specify a folder, it doesn’t work.
I attach the log file in that folder.

logs.zip (4.1 KB)

TL;DR: Please fix the crash on MacOS when Exporting to C/C++.

Like the poster above, I’m on MacOS and incur a 100% lockup when attempting, but only when exporting to C (which I need) and not to Python (which I can’t use in embedded). Whether exporting a file or the project, the app will effectively die, needing a force-quit. (A “kill” on other OSes.)

I gave some brief thought to machine/hand-editing the python into C/C++ before I realized how insane that sounded when it’s clearly the intent for the program to actually do the right thing instead, so i decided to dig into the forum and ask for that instead. :slight_smile:

Grid layout and custom widgets (I’ll probably soon need a scrolling columnar listview and a R-L slowly scrolling oscilloscope or hearbeat-style graph, though all of those are probably far out for you) are high on my Wish List, I can probably use use an image here as a placeholder and use SLS to design the chrome around it.

I also had the problem that I’ve since seen mentioned here that the out-of-box experience on MacOS is weird with the size of all the object set to microscopic mode. Blowing them up to about 175% is necessary on my MBP for the UI to be practical. Since Pixels on a 227dpi retina screen don’t map well to the less expensive LCDs that most of our embedded devices will be using, blowing the screen view up to about 250% (which isn’t in the drop-down) is necessary for pixel-level layout on our tiny screens. Having bad default on a first run is an unnecessary bad first impression and hopefully is an easy fix.

I’m building open source software with LVGL and was excited to see something like QtCreator for LVGL just because I was (am) NOT looking forward to a bunch of “upload, reboot, move this over two pixels” cycles, so I really hope you succeed with this.

Thank you!

It should be the same issue as @pruge has: We still don’t know why, but on M1 (or may on the newest MacOS?) a library file which formats the source code, can’t be loaded. We are working on it and will fix it in the next release.

SquareLine also has a UI scale option here:

Any update on when this will be fixed? I downloaded to evaluate the export functionality, but cannot use this at all.

I tried on my M1 Mac and a non M1 Mac and both hit the wheel of death when exporting.
The export of Python appears fine.

We can fix it only in the next release. :frowning:

The problem is that on Mac in some cases SquareLine can’t find a library to format the exported code.

Any news about this issue or some release date? Export to C/C++ is not working on M1 Mac.

We are on it. I hope we can release v1.1 this month.

3 Likes

I have read in another post, that you are planning 1.1 for this week.
Is it possible to be related until the end of the week? Thank you for your awesome job.

Has this been fixed? I’m hitting the same bug right now - M1 mac, latest versions of everything. I really want to use squareline studio, but I can’t achieve anything on a mac.

I had the same problem and realized running in Rosetta solves the problem. CMD + ‘i’ or CTRL + Click on the Squareline_Studio app in the Applications folder and click ‘Get Info’. Then tick the box ‘Open Using Rosetta’.

Now run the Squareline_Studio app as normal and export should work.

1 Like

Hi, this is my first post, but I am experiencing the same problem on windows 8, when I try to export a project I get the (not Responding) on squareline, it happen to me in the 1.1 and 1.2 versions, so far I had never been able to test a project

Latest supported Visual C++ Redistributable downloads | Microsoft Learn

instal x86 or x64 latest

it is x64 just win 8, in another computer I can create the UI, but can’t upload it, in my win 8 I cannot create the project but I can upload it, which by the way only shows black screen…