UI gone - not showing screen properly

What do you want to achieve?

One of my screen is gone when I open a saved project which was running correctly previously. It could not be shown.

Besides, I can’t interact with all my widgets in Play Mode even with other screen that is showing UI properly, after this UI issue happened.

What have you tried so far?

I tried restarting Squareline Studio and my machine, but the problem persists.

Screenshot or video



  • SquareLine Studio version: 1.1.1
  • Operating system: Windows 11
  • Target hardware: AMD Ryzen 7 4800U

\AppData\LocalLow\Game-Ever Bt_\SquareLine_Studio\Player.log is provided alongside project file in attached .zip file.

I would like to upload logs and project file. But when I upload the zip file, I was prompted by the forum with “Sorry, new users can not upload attachments.”

Edit: I can upload files now after my user level is upgraded by the system. For other future new users with the same limitation, you have to participate in other post and have some kind of activities. Then, the system will upgrade you. Check this post for more detail - Understanding Discourse Trust Levels.

Although I could not see the GUI in Squareline Studio SLS, the code generated by SLS is completely fine and usable. I tested it on a 7 inch touch screen monitor. Everything works fine.

Due to 8MB file upload limit of the forum, I uploaded it to Google Drive instead. Here is the file with the following files and folders attached:

  • .spj
  • .sll
  • Player.log
  • assets/
  • cache/

I tried the built in 3D printer demo. There is no problem with it.

Please attache the logs as described here and also attach a screenshot about the Console window.

The logs:

Player.zip (904 Bytes)

Screenshot about the Console window:

The above “player” log is under the Squareline Studio v1.1.1

I also tried v1.2.0 . The problem persists.

I also have a blue lightning logo on the upper part of my Squareline Studio.

Does it work if you load the original example?

Yes, it does work for the original example.

I have included the project files a month ago. Please check if that helps.

Hi Christine nice foto
in your project seems is Screen2 corrupt remove it and recreate
too good is dont use space in screen names

Info for all with same trouble, error is on screen last rendered on start before dont rendered…
SQS is long way from stable, but fine project

Thanks for sharing your project. We have tried it out and found the issue.

Screen 2 was HIDDEN and it made LVGL crash. We will remove this option from the screen as it shouldn’t be used.

Thanks a lot. I’ll try to unhide it to see if it works.

Thank you for your advice. I will prevent using space in names in the future. :slight_smile:

Hello, can you help me, i seem to be in the same situation :frowning:
the screen is not hidden and i only have 1 screen: I also have the Lightning bolt symbol on lvgl studio

You don’t share much about your exact situation but it might be a corruption in your project-file. Maybe recovering the .spj file from ‘autosave’ folder would help you too.