UI won't load widgets past one with a custom font

I have a custom font named “montserrat ext 22” which I applied to a label on the third screen in my project. When the project loads, anything (widgets and screens) beyond that one fail to load. See screen shot:

removing the custom font from the label returns the behavior back to normal:

Edit: I tried another font and it worked. The font that is not working has a extended character set:


Edit: Console show a failure evaluating the font:


Edit: Changed the font name to “f1” and it’s working, so maybe something with the naming?.. will test more.

Calling the font “montext 22” seems to work also, so I believe the issue is with a long font name or a name with too many spaces.

Thanks for the feedback. I could reproduce the problem, it seems the micropython server that SquareLine Studio uses in the background, doesn’t like any fonts created with a name that begins with ‘montserrat’, no matter if there’s a space after it or not. Font named ‘Montserrat’ (with 1st letter capital) still worked so it seems micropython checks for ‘montserrat’ (all lower case) string to find built-in fonts. We’ll look for the cause. (The conclusion is the same for your other topic opened for this case: Add non default characters to the LV_FONT_MONTSERRAT_22 font )