Unresponsive(File Saving in Progress)

What do you want to achieve?

I want to save the project.

What have you tried so far?

I have opened the autosaved versions and get the same result.(it becomes unresponsive when i try to save)

I can save a different project, just not this one.


  • SquareLine Studio version:
  • Operating system:
  • Target hardware:

I have no idea what changed(nothing to my knowledge), but I reopened the project that was causing SLS to crash again today and it saved without crashing.

I think it may have something to do with the color wheel. I added a color wheel at a little after 8:00 and the last autosave/backup file i have is labeled 8:18am even though the folders have later time periods in the day on them.(The time period on the file stays 8:18am, even though the folder says its 1:32pm, 4:45pm, etc for the same day)

I don’t get any unresponsive dialog in Windows, but SDS is unresponsive for at least 5 seconds when saving my project and during autosave periods. If I try to do anything during this then the app is greyed out when Windows is determining if the app is unresponsive.

It would be nice if saving can be passed to a background thread so the UI still works while saving. The autosave is nice but directly interrupts my work sometimes. I don’t want to turn it off because I still hit instances where the undo button deletes work in v1.3.1 and you cannot get it back in the UI.

Can you send the broken project to forum@squareline.io, so that we can check it out?