Upgraded to 1.4.1. select board espressif esp32-s3-lcd-ev-board

What do you want to achieve?

What have you tried so far?

selecting esp-box creates project, but is wrong for s3-lcd-ev-boarrd

Back to lcd-ev-board tried selecting 1.0.0 and 1.0.1, both report missing binary

Screenshot or video


  • SquareLine Studio version:
    1.4., this project was working in 1.4.0!

  • Operating system:
    Windows 11

  • Target hardware:

Thanks for reporting this. We could reproduce the problem with the downloading of this board and working on the solution. Until that you can manually create a zip file from the __ui_project_name__ folder GitHub repository GitHub - SquareLineStudio/board_esp32_s3_lcd_ev_board at v1.0.1 (the zip should contain the whole folder with the files in it, not just the files) and copy the zip into the ‘SquareLine/boards’ folder beside the others in the ‘Espressif’ subfolder, and then restart SquareLine Studio, and then you should be able to use the board-template. I attached the zip here too for easier solution.
esp32_s3_lcd_ev_board.zip (4.0 KB)

We managed to fix the download issue with the esp32-s3-lcd-ev-board, and it is now working.

1 Like