Where is the "Editable View" in SquareLine Studio?

What do you want to achieve?

I just downloaded SquareLine Studio for Linux. I am trying to create a simple project that just displays an image. Can someone explain what I have to do to use this software? It doesn’t seem to do anything.

What have you tried so far?

I have read the manuals, and it seems to indicate that I should be able to place components and scale them in the “Editable View”. I can find no such thing in the software. I can see all the panels, but in the middle top, all I see is a blue home icon above a grey screen. No matter what I add Heirarchy tab, nothing ever appears in the grey screen. There is also a blue arrow that activates “Play mode”, but nothing ever plays.

I have tried both a custom project and examples.

Screenshot or video


  • SquareLine Studio version: 1.1.1
  • Operating system: Ubuntu Linux 18.04
  • Target hardware: x86_64

So just some more information. If anyone can please respond and help me out it would be appreciated. I understand now that this gray center screen is a common problem and means something is broken. I’ve also tried v1.1.0 and v1.0.5. They all give the same result.

SquareLine really needs to make a troubleshooting section telling everyone if you experience this, your installation is broken. I wasted a lot of time trying to figure out that what I was supposed to see simply wasn’t there.

After a search, many of the responses to problems such as these ask people to submit log files. I can not find any .log file created anywhere on my machine, either in the installation directory or in the ~/SquareLine workbench directory that it created for me to store my projects. A log file, any log file, would be extremely helpful here. I recommend SquareLine make this a priority for their software and include a troubleshooting section on where to view it.

With regards to libraries, “ldd SquareLine_Studio.x86_64” reports the following:

ldd SquareLine_Studio.x86_64
linux-vdso.so.1 (0x00007fffa083e000)
UnityPlayer.so => /home/pp/lvgl/squareline_v1.1.1/./UnityPlayer.so (0x00007f419225e000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f4191ec0000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f4191ca8000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f4191a89000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f4191698000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f4191494000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f419128c000)
/lib64/ld-linux-x86-64.so.2 (0x00007f419441c000)

I understand there are also some micropython servers bundled. They report the following:

lvgl/lvgl_v8_2_0/server/micropython: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29’ not found (required by lvgl/lvgl_v8_2_0/server/micropython)
linux-vdso.so.1 (0x00007ffcc329e000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f628f098000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f628ecfa000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f628e909000)
/lib64/ld-linux-x86-64.so.2 (0x00007f628f583000)

And the same GLIBC_2.29 error message on the other micropython server:

lvgl/lvgl_v8_3_3/server/micropython: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29’ not found (required by lvgl/lvgl_v8_3_3/server/micropython)
linux-vdso.so.1 (0x00007fff02fe0000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f40c9422000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f40c9084000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f40c8c93000)
/lib64/ld-linux-x86-64.so.2 (0x00007f40c990d000)

I’m not sure if these micropython servers are necessary, but if they are, the version of GLIBC used with Ubuntu 18.04 is 2.27, not 2.29.

$ ldd --version
ldd (Ubuntu GLIBC 2.27-3ubuntu1.5) 2.27

This page: Installation | SquareLine Studio
clearly says Ubuntu 18.04 and newer is supported. Is this not true?

Is there something I can do to make this work? Is there a docker image somewhere which will simply make this all run?

Any help on how to resolve this is appreciated.


We have added a new version of LVGL to SLS and forgot to use Ubuntu 18.04 to build. Sorry for the inconvinience…

Please extract and copy micropython.zip (1.0 MB) to SquareLine_Studio_Linux_v1_1_1/lvgl/lvgl_v8_3_3/server. If you confirm it’s working well, we will update SLS v1.1.1 with the new server.