Still unable to export on Mac M1 (1.1.0 release)

What do you want to achieve?

Exporting project on MacBook Pro M1 still broken. Got stuck in “export in progress”. In Activity monitor Squareline studio is not responding.

Related issue on previous version:

What have you tried so far?

Tried reinstalling and exporting multiple times.

Screenshot or video


  • **SquareLine Studio version: 1.1.0 **
  • **Operating system: MacOS BigSur 11.6.7 **
  • Target hardware: ESP32


Please send us the logs to be sure what the problem is. They should be in ~/Library/Logs/Unity

me too (macbook pro m1)
The directory ~/Library/Logs/Unity does not exist.

The log path is from the official Unity website. Anyway, we will check where it is on Monday.

Or you can search for “Player.log”

@kisvegabor Sorry for later reply. There are no logs anywhere as @sorke mentioned.
Tried to search for “Player.log” on whole HDD but no catch.

Btw. I am an Espressif developer working on Arduino project. I will try to help you and test this issue as much as possible :slight_smile:

We have checked that I sent an incorrect location indeed.
It should be in ~/Library/Logs/Game-Ever Bt_/SquareLine_Studio/Player.log

It’s strange that you can’t find it with search on the whole HDD.

Oh, great, thank you! :slight_smile:

Sending the log :slight_smile:
Player.log.txt (2.7 KB)

I agree it is strange that I was not able to find that by searching on HDD.

Have you already tried Rosetta?

Ok I in the information tab about the SquareLine_app I checked “Open using Rosseta” and export now works :slight_smile:

I think you should pin this on Forums or Add some readme.txt to MacOS zip you download to install.
Or maybe make the app “Open using Rosetta” a default option.

Great, thanks for the feedback!

We will update the docs, add a README, and check how to make it start automatically with Rosetta.

1 Like

cool! :+1: