V1.2.2 is released!

Hi guys,

We have just released v1.2.2!

Besides many fixes and smaller features these are the main changes in the new version:

New features
Use multiple cores during exporting
Include ui_comp.h in ui.h
Add a hook for component creation
Initial actions on startup
Allow deleting components from the editor
image animation widget
Add lv_events.h even if the “Call function” events are not exported
Allow editing flex properties in components

Fixing bugs related to components
Fix the list when right clicking on a widget on a screen
Add extern “C” {} to ui_comp.h
Add scrollbar style to the panel widget
Make rendering faster
Fix disappearing style properties on the screens
Fix dropdown styles if they are components

You can get the new version from the usual Download page.

If you find any issue, please open a new topic here.

Happy SquareLine-ing! :slight_smile:

1 Like

Since I updated SquareLine I can’t compile the exported code anymore. It throws unreferenced functions.
"/Users/ftrillo/Library/Arduino15/packages/esp32/tools/xtensa-esp32s3-elf-gcc/esp-2021r2-patch5-8.4.0/bin/…/lib/gcc/xtensa-esp32s3-elf/8.4.0/…/…/…/…/xtensa-esp32s3-elf/bin/ld: /private/var/folders/sd/v1hl8g1s4rv6mnlk_3l7487h0000gn/T/arduino/sketches/C587036DA62E231AE0863387CBE688C9/sketch/objs.a(ui.c.o):(.literal.OpaOn_Animation+0xc): undefined reference to lv_anim_set_deleted_cb' /Users/ftrillo/Library/Arduino15/packages/esp32/tools/xtensa-esp32s3-elf-gcc/esp-2021r2-patch5-8.4.0/bin/../lib/gcc/xtensa-esp32s3-elf/8.4.0/../../../../xtensa-esp32s3-elf/bin/ld: /private/var/folders/sd/v1hl8g1s4rv6mnlk_3l7487h0000gn/T/arduino/sketches/C587036DA62E231AE0863387CBE688C9/sketch/objs.a(ui.c.o):(.literal.ui_Scn1_Home_screen_init+0x2c): undefined reference to ui_font_Small_Font’
/Users/ftrillo/Library/Arduino15/packages/esp32/tools/xtensa-esp32s3-elf-gcc/esp-2021r2-patch5-8.4.0/bin/…/lib/gcc/xtensa-esp32s3-elf/8.4.0/…/…/…/…/xtensa-esp32s3-elf/bin/ld: /private/var/folders/sd/v1hl8g1s4rv6mnlk_3l7487h0000gn/T/arduino/sketches/C587036DA62E231AE0863387CBE688C9/sketch/objs.a(ui.c.o): in function lv_anim_set_delay': /Users/ftrillo/Documents/Arduino/libraries/lvgl/src/../src/misc/lv_anim.h:155: undefined reference to lv_anim_set_deleted_cb’
/Users/ftrillo/Library/Arduino15/packages/esp32/tools/xtensa-esp32s3-elf-gcc/esp-2021r2-patch5-8.4.0/bin/…/lib/gcc/xtensa-esp32s3-elf/8.4.0/…/…/…/…/xtensa-esp32s3-elf/bin/ld: /private/var/folders/sd/v1hl8g1s4rv6mnlk_3l7487h0000gn/T/arduino/sketches/C587036DA62E231AE0863387CBE688C9/sketch/objs.a(ui.c.o): in function lv_anim_set_values': /Users/ftrillo/Documents/Arduino/libraries/lvgl/src/../src/misc/lv_anim.h:168: undefined reference to lv_anim_set_deleted_cb’
/Users/ftrillo/Library/Arduino15/packages/esp32/tools/xtensa-esp32s3-elf-gcc/esp-2021r2-patch5-8.4.0/bin/…/lib/gcc/xtensa-esp32s3-elf/8.4.0/…/…/…/…/xtensa-esp32s3-elf/bin/ld: /Users/ftrillo/Documents/Arduino/libraries/lvgl/src/…/src/misc/lv_anim.h:167: undefined reference to `lv_anim_set_deleted_cb’
collect2: error: ld returned 1 exit status

exit status 1

Compilation error: exit status 1"
I had to downgrade squareline to 1.2.1.
Im using (and project configured to) lvgl 8.2.0

I too have the same error!

Please go to project settings and set LVGL version to v8.3.4.

lv_anim_set_deleted_cb was added only in LVGL v8.3. If it solves the issue we will figure out hoe to support v8.2 too.

This is a broken release for windows users. Seemed fine on mac. Please address the bugs raised, like screen not found and font generation errors due to -r argument passed to generator.

Please confirm if the lv_anim_set_deleted_cb is solved with LVGL >v8.3.

I haven’t seen a related topic. Could you describe this issue in more detail?

it’s in the broken screen issue. Basically it passes -r argument to java font generator with no value, rather than not providing the -r argument at all if the range is not supplied. To be fair I had not intentionally cleared the character range (maybe a bug to do with upgrading) so was expecting full ascii, and was surprised by the error entirely.

Still cant use project settings in file menu.
If i setup custom LCD size here is overwrited , and too still cant change theme usw.

I encountered the following problem in v1.2.2: Project failed to open in new version of Squareline Studio